联系我们:微信:qhltcn(扫码) | QQ:116589960(扫码) | 电话:13581020706 2018.09.21期货论坛关于维护重要通知!!!
返回列表 发帖

[大智慧指标] [转载]价值连城的好指标,好就顶(源码,副图,无未来)

[大智慧指标] [转载]价值连城的好指标,好就顶(源码,副图,无未来)

公式源码:
  1. MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
  2. G1:=IF(-MMS>95,0,20);
  3. UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0
  4. AND G1)+1);
  5. 明日均线:REF(C,2)*2-REF(C,5),LINETHICK0,COLOR550055 ;
  6. 后日均线:REF(C,1)*2-REF(C,4),LINETHICK0,COLOR008800;
  7. 大后天均线:C*2-REF(C,3),LINETHICK0,COLOR008888;
  8. KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
  9. KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
  10. 趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
  11. AA:=-100*(趋势线-CLOSE)/趋势线;
  12. AC:=(EMA(AA,5) );
  13. SSL:=EMA(CLOSE,3);
  14. MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
  15. MM:=MA(MMV,1);
  16. STICKLINE(((SSL>MM)),SSL,MM,0.01,0),COLORRED;
  17. SA:=(MM*0.985);
  18. SS:=(MA(CLOSE,5));
  19. DD:=(MA(CLOSE,13));
  20. GG:=(MA(CLOSE,21));
  21. 捞钱手:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF;
  22. {IF(SSL<MM,捞钱手,DRAWNULL),LINETHICK2,COLORFFFFFF;}
  23. VAR2Y:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
  24. VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);
  25. VAR4Y:=REF(CLOSE,1);
  26. VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE -
  27. VAR4Y)),6,1)) * 100);
  28. VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE -
  29. VAR4Y)),12,1)) * 100);
  30. VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE -
  31. VAR4Y)),24,1)) * 100);
  32. VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) *
  33. 100);
  34. VAR9Y:=SMA(VAR8Y,3,1);
  35. VARAY:=SMA(VAR9Y,3,1);
  36. VARBY:=((3 * VAR9Y) - (2 * VARAY));
  37. VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));
  38. VARDY:=((100 - CROSS(76,VAR5Y)) AND (VAR3Y > (5*20)));
  39. DRAWICON(((CROSS(76,VAR5Y) AND
  40. (VAR3Y>5))),(HIGH*1.01),2),COLORFFFFFF;
  41. VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 -
  42. 30))) AND (VAR2Y > 3)) * 30);
  43. VARFY:= - ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26)))
  44. * 10);
  45. DRAWICON((CROSS(VARFY,(0 - 9))),(LOW * 0.998),1);
  46. 能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));
  47. 上开:=O;
  48. 上收:=C;
  49. 上高:=H;
  50. 上低:=L;
  51. JJ:=(上开+上高+上低)/3;
  52. A:=EMA(JJ,4);
  53. 智能黄金线:A,COLORYELLOW,LINETHICK1;
  54. B:=REF(A,1);
  55. STICKLINE(((SSL<MM)),捞钱手,智能黄金线,0.01,0),COLORFFFF00;
  56. VA1:=EMA(上收,8);
  57. VA2:=EMA(上收,20);
  58. DRAWTEXT(CROSS(VA2,VA1),VA1*1.10,'止 损'),COLORYELLOW;
  59. DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND
  60. 智能黄金线>REF(智能黄金线,1),VA1*0.98,'★买入'),COLOR00FF00;
  61. 选手A:=MA(上收,3);
  62. 箱顶A:=MA(REF(HHV(上收,6),1),3);
  63. 箱底A:=MA(REF(LLV(上收,3),1),3);
  64. T1:=MA(上收,20)>=REF(MA(上收,20),1);
  65. T2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND T1;
  66. T3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;
  67. 选手:=MA(上收,2);
  68. 箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
  69. 箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
  70. T4:=CROSS(选手,箱底) AND 箱顶/箱底>110/100;
  71. T5:=CROSS(箱顶,选手) AND 箱顶/箱底>110/100;
  72. VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
复制代码
# Z; R, B# V+ v0 m! f

' t' W7 T; f) k2 b8 c0 X
微信截图_20181011134000.png
2018-10-11 13:41
官方开户、量化、广告及合作事宜,微信:qhltcn  QQ:116589960(上班时间:周一至周五上午8:30-下午17:00)

返回列表