联系我们:微信:qhltcn(扫码) | QQ:116589960(扫码) | 电话:13581020706 2018.09.21期货论坛关于维护重要通知!!!
返回列表 发帖

[通达信指标/源码] [转载]通达信的发动机指标

[通达信指标/源码] [转载]通达信的发动机指标

002.png
2018-10-9 15:44

" w9 b0 S: ~2 l6 R发动机副图
/ Q" b* K) z* d- E5 \9 K2 q# E; \! B9 \
  1. CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
  2. YJD:=(EMA(CS,3)-50)*2;
  3. 能量线:YJD;{探测能量动力,很像KDJ公式的J值}
  4. 中:=0;
  5. {PARTLINE(YJD,中线);}
  6. DRAWTEXT(CROSS(YJD,中),0,'●'),COLORRED;{买入点3}
  7. VAR7:=(1.1)*CLOSE;
  8. VAR8:=(0.9)*CLOSE;
  9. VAR9:=100*(WINNER(VAR7)-WINNER(VAR8));
  10. 能量线1:=能量线>=0;
  11. 能量线2:=能量线<=0;
  12. {原 庄家克星的抄底逃顶公式 将山水线改名抛留线,去掉倒影线}
  13. VAR1:=(2*CLOSE+HIGH+LOW)/4;
  14. VAR2:=LLV(LOW,5);
  15. VAR3:=HHV(HIGH,4);
  16. SK:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,4);
  17. SD:=EMA(0.667*REF(SK,1)+0.333*SK,2);
  18. SJ:=2*SK-1*SD;
  19. SKD差:SK-SD,COLORRED,NODRAW;
  20. VAR4:=(HHV(HIGH,4)-VAR1)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
  21. {倒影: SMA(VAR4,4,1),COLOR889999,LINESTICK;}
  22. VAR5:=(VAR1-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
  23. VAR6:=SMA(VAR5,2,1);
  24. 抛留线:SMA(VAR6,2,1),COLOR889999,LINESTICK;
  25. DRAWBAND(能量线,RGB(255,48,48),能量线1,RGB(0,148,48));
  26. 金叉:IF(CROSS(SK,SD)AND 抛留线<35,抛留线,0),COLORFFFFFF,LINETHICK2;{买入点1}
  27. 金叉1:IF(CROSS(SK,SD)AND SK<50,20,0),COLORRED,LINETHICK2;{买入点2}
  28. STICKLINE(CROSS(金叉,0.1),80,-80,0,0),COLORFFFFFF;
  29. 线:SMA(VAR6,2,1),COLOR889999;
  30. IF(抛留线>REF(抛留线,1),抛留线,DRAWNULL),COLORRED,LINETHICK2;
  31. IF(抛留线<REF(抛留线,1),抛留线,DRAWNULL),COLORWHITE,LINETHICK2;{红留,变白一定卖}
  32. {PARTLINE(倒影,倒影<REF(倒影,1),RGB(0,255,0),倒影>REF(倒影,1),RGB(250,250,0)),LINETHICK2;}
  33. IF(能量线>REF(能量线,1),能量线,DRAWNULL),COLORRED,LINETHICK2;
  34. IF(能量线<REF(能量线,1),能量线,DRAWNULL),COLORYELLOW,LINETHICK2;{黄不进,变红后市可看好}
  35. STICKLINE(CROSS(能量线1,0.1),80,-80,0,0),COLOR0000FF;
  36. 顶线:80,COLORRED;
  37. 强势:65,COLORFFFFFF,NODRAW;
  38. STICKLINE(CLOSE>0,65,65,1.5,0),COLORFFFFFF;
  39. 转势:-65,COLORRED;
  40. 底线:-80,COLORGREEN;
  41. DRAWTEXT(ISLASTBAR,顶线,'  80  顶线'),COLORRED;
  42. DRAWTEXT(ISLASTBAR,强势,'  65  强势'),COLORFFFFFF;
  43. DRAWTEXT(ISLASTBAR,中,'  00  中线'),COLOR00FFFF;
  44. DRAWTEXT(ISLASTBAR,转势,' -65  转势'),COLORRED;
  45. DRAWTEXT(ISLASTBAR,底线,' -80  底线'),COLORGREEN;
  46. {庄家克星  神奇均线主图}
  47. VAR10:=(2*CLOSE+HIGH+LOW+OPEN)/5;
  48. A1:=(EMA(VAR1,3)+EMA(VAR1,6)+EMA(VAR1,12)+EMA(VAR1,24))/4;
  49. A2:=EMA(A1,2);
  50. A3:=EMA(A2,2);
  51. A4:=EMA(A3,2);
  52. A5:=EMA(A4,2);
  53. A6:=EMA(A5,2);
  54. A7:=EMA(A6,2);
  55. A8:=EMA(VAR1,2.78)*1.028,COLORFFFFFF,LINETHICK1;
  56. A9:=MA(OPEN,3.2)*1.028,COLORGREEN,LINETHICK1;
  57. 短线:=A8;
  58. 中线:=A9;
  59. DRAWTEXT(CROSS(短线,中线),-65,'进'),COLORRED;
  60. DRAWTEXT(CROSS(中线,短线),-65,'退'),COLORGREEN;
复制代码
官方开户、量化、广告及合作事宜,微信:qhltcn  QQ:116589960(上班时间:周一至周五上午8:30-下午17:00)

返回列表